Unable to print Create Shipping Labels

Issue

The SendPro C, SendPro+ will not print a label and no error message appears.

Cause

  • There may be a problem with the printer.
  • The top cover may be open.

Resolution

Solution 1: If the printer has a solid green light

  1. Make sure you connect the USB cable to both the printer and SendPro C, SendPro+ device.
  2. Switch the USB cable and plug it into another USB port available on the back of the device.
  3. Restart the device:
    1. Unplug the power cord. The screen should turn off after 10 seconds.
    2. Wait one minute.
    3. Plug the power cord directly back into a wall outlet. Check that the wall outlet is functioning correctly.
    4. Quickly tap and release the power button to turn the device back on.

Solution 2: If the printer has a flashing red light

  • Load and align the labels correctly.
  • Make sure that the paper sensors are clear from any dust or debris.
  • Close the top cover firmly.